x264guiEx 1.xx/2.xx 導入

2014.04.19
動作環境変更
2013.06.24
x264guiEx 2.xx導入に対応
2013.05.10
少々記事修正&リンク修正
2013.03.14
その他の設定の紹介記事へのリンクの追加。
2013.03.10
簡易インストーラを使った方法の動画を追加。
アップデート方法へのリンクも追加。
2012.10.23
簡易インストーラを使った方法に書き換え。

手動で行う方法は、
x264guiEx 2.xxの導入 (手動)に。
以前のx264guiEx 1.xxを手動で行う方法は
x264guiEx 1.xxの導入 (手動)に。

その他関連記事
x264guiEx 1.xx についていくつか…
x264guiExのアンインストール
x264guiExのプロファイルについてのいろいろ
x264guiEx ログウィンドウについてる機能
MediaInfoによるx264のオプション表示の取り込み方法
x264guiExの上限設定
x264guiExでBluray用出力
x264guiExのアップデート方法
x264guiExのその他の設定

注意
以前のx264guiやx264guiExとは自動マルチパスの方法が異なります。
2passエンコードでエラーが出た場合はこちらを見てみてください。





拡張 x264 出力(GUI) Ex は、seraphy氏 の 拡張 x264 出力(GUI) を改造し、
パイプを利用することで、x264を分離したものです。

x264が別プロセスであるため、64bitOSでは64bit版のx264が使え、
32bitのx264に比べ、エンコードの高速化が期待できます。(0~15%程度)

またパッチをあてたものなどさまざまなx264を選択することができます。
多くの場合x264の更新のみで最新版のx264を使用できます。



重要事項




無保証です。自己責任で使用してください。
拡張 x264 出力(GUI) Exを使用したことによる、いかなる損害・トラブルについても責任を負いません。
つまり、こんなのってないよっていう状況に陥っても知りません。





動作環境




Windows Vista,7,8,8.1 (x86/x64)
Aviutl 0.99g4 以降
Aviutl 0.99k2 以降 推奨





Aviutl + x264guiExでエンコード (動画)



Aviutl + x264guiExでエンコードを行う方法を動画で紹介しています。
・Aviutlのダウンロード・インストール
・L-SMASH Worksの追加
・拡張編集の追加
・x264guiExの追加
・エンコードしてみる+ニコ動用エンコの話
あたりの一連の流れを追っかけています。

また、x264guiExの導入のみについては、
この後スクリーンショットでも紹介していきます






ダウンロード




x264guiExの記事の下のほうの「
ダウンロード>>」をクリックし、その先のページからダウンロードできます。




準備



簡易インストーラで、さくっと準備。

手動で行う方法はx264guiEx 1.xxの導入 (手動)を見てください。

アップデートの場合は、x264guiExのアップデート方法をご覧ください。

簡易インストーラでは、

.NET Framework
x264_L-SMASH
neroaacenc
L-SMASH muxer

などを自動ダウンロード・配置・設定。

実行ファイルの場所の指定まで行うので、あとは設定画面を開いて、設定いじってエンコード開始するだけ。

x264_L-SMASHはPOP様がビルドしてくださっているものをダウンロードします。POP様、ありがとうございます!



簡易インストーラの使い方




x264guiEx2_startup_01

x264guiEx2_startup_02

x264guiEx2_startup_03

x264guiEx2_startup_04

x264guiEx2_startup_05

x264guiEx2_startup_06

x264guiEx2_startup_09

x264guiEx2_startup_10

x264guiEx2_startup_11

x264guiEx2_startup_12

x264guiEx2_startup_13


プリセット、プロファイルについては、x264guiExのプロファイルについてのいろいろを見てください。

とまあ、こんな感じ。

あとは
・適当に設定
・OKをクリックして設定画面を閉じる
・保存
とするだけ。

はじめは短い動画でいろいろ試してみると良いかもしれません。

OK をクリックして、設定画面を閉じる
出力ファイル名を指定して、保存 -> エンコード開始。

エンコードにはかなり時間がかかることがあります。

ファイルが出力されれば終了です。再生できるか確認してみてください。

お疲れ様でした。

この簡易インストーラを使用する方法は、動画でも紹介していますので、わかりにくい場合は、そちらを見てみてください。




x264guiExのその他の機能について




x264guiExの渡すオプションについて




x264に渡される予定のコマンドが設定画面下部表示欄に出るようになっています。
実際には、下部表示欄に出たものに、次のコマンドを自動的に追加したものが渡されます。
- コマンド入力欄のコマンド
- 解像度情報 (--input-res)
- 色空間情報 (--input-csp)
- フレーム数情報 (--frames) (自動フィールドシフト使用時を除く)
- フレームレート情報 (--fps) (--tcfile-in を指定した場合は付加されない)
- 出力先情報 (-o)
- 入力元情報 (パイプ "-")
また、一部、GUI独自の機能としてエンコード時に自動的に置換されるオプションがあります。



使用可能なx264について



x264guiExでは多くのx264.exeに対応しており、x264 r1673 (2010年 7月頃)以降のものであれば使用可能です。しかし、なるべく最新のものを使用することをおすすめします。

x264.exeは多くの方がビルドしてくださっています。
http://pop.4-bit.jp/
http://x264.nl/
http://www.xvidvideo.ru/x264-video-encoder/
http://komisar.gin.by/
http://x264.fushizen.eu/
http://sdmr.sblo.jp/
http://astrataro.wordpress.com/
http://k4095-takuan.blogspot.jp/

x264guiEx簡易インストーラでは、POPさんのx264_L-SMASHをダウンロードさせて頂いております。ありがとうございます!



mkv出力について




x264guiExはmkv出力にも対応しています。
その際にはmp4box/L-SMASHではなく、mkvmergeが必要になります。

mkvmerge (mkv muxer, mkv作成時に必要)
http://www.bunkus.org/videotools/mkvtoolnix/




自動フィールドシフトを使用する場合



拡張タブの「自動フィールドシフトを使用する」にチェックを入れる必要があります。



neroaacenc以外の音声エンコーダを使用する



x264guiExでは、neroaacenc以外の音声エンコーダを使用した音声エンコードも可能です。

以下に挙げる音声エンコーダに対応しています。また、x264guiEx.iniに追加することで他のエンコーダにも対応できるかもしれません。


qtaacenc (aacエンコーダ)
http://tmkk.pv.land.to/qtaacenc/ (要QuickTimeインストール)

lame (mp3 エンコーダ)
http://www.rarewares.org/mp3-lame-bundle.php

FAW+fawcl (FakeAACWave, aacを無劣化移行)
http://2sen.dip.jp/cgi-bin/friioup/upload.cgi?search=FakeAacWav&sstart=0001&send=9999

ext_bs (PVシリーズaac抽出)
http://www.sakurachan.org/soft/mediatools/

ffmpeg (as AC3 encoder)
http://blog.k-tai-douga.com/

oggenc2 (Ogg Vorbis, mkv用)
http://www.rarewares.org/ogg-oggenc.php

qaac/refalac (aacエンコーダ、alacエンコーダ)
http://sites.google.com/site/qaacpage/

mp4alsrm23 (MPEG4 ALS (MPEG4 Audio Lossless Coding))
http://www.nue.tu-berlin.de/menue/forschung/projekte/beendete_projekte/mpeg-4_audio_lossless_coding_als/parameter/en/
※Reference Software のとこにある MPEG-4 ALS codec for Windows - mp4alsRM23.exe

flac (可逆圧縮)
http://www.rarewares.org/lossless.php
http://flac.sourceforge.net/download.html




設定画面にある主な機能の紹介



x264guiExConf


それぞれについて、以下のリンク先の記事で詳しく紹介しています。

1. 自動マルチパス・上限付き品質基準VBRモードと上限設定について
x264guiExの上限設定

2. 各プロファイルについて
x264guiExのプロファイルについてのいろいろ

3. その他の設定
x264guiExのその他の設定



注意事項




mp4boxについて
mp4boxは様々な方が、ビルドし、配布して下さっていますが、なるべく最新のものを使用してください。

こちらの場所で配布されているmp4boxはすこし古いようです。(2012年4月現在)
http://www.videohelp.com/tools/mp4box
※こちらで配布されているmp4boxの 0.4.6 rev2735 はMSVCR100.dllが必要なようです。MSVCR100.dllはVisual C++ 2010 再頒布可能パッケージ (x86)に含まれますので、インストールされていない場合Visual C++ 2010 再頒布可能パッケージ (x86)をインストールしてください。

自動フィールドシフト使用上の制限
 自動フィールドシフト使用時はx264のvbv関連のものは正しく反映されません。これは、エンコード中にタイムコードを取得して、あとからタイムコードを反映させるためです。自動フィールドシフトのタイムコード取得はエンコードを1回は回さなければ得られないため、どうしようもありません。

2passの制限
重要なことですが、自動フィールドシフト(afs)を有効にした場合、
「自動マルチパス」以外の方法での2-pass(およびn-pass)エンコードは
失敗します。これは afsによるdrop数が2pass目以降
事前にわかっていなければならないためです。
自動フィールドシフトを使わない場合は問題ないです。


・パイプを作成するには、CreateProcess関数なるものを使うのですが、調べると管理者権限が必要なことがあるっぽいことが書いてありますのでそこらへんよろしくです。



その他関連記事
x264guiEx 1.xx についていくつか…
x264guiExのアンインストール
x264guiExのプロファイルについてのいろいろ
x264guiEx ログウィンドウについてる機能
MediaInfoによるx264のオプション表示の取り込み方法
x264guiExの上限設定
x264guiExでBluray用出力
x264guiExのアップデート方法
x264guiExのその他の設定



バグってたらどっかのコメント欄とかメールとかにでも。バグったタイミングとか、エラーメッセージとか、ログウィンドウの表示をコピペとかしてくれるともっと助かります。はい。
スポンサーサイト

コメントの投稿

非公開コメント

No title

ビルド後のイベントでAviUtlのフォルダにコピーするようになっていますが、うちのパスと違うので失敗し、ビルドが失敗したとなります。ファイルはできているので使えるのですが、ややこしいのでリリース用のソースからは削除した方がいいのではないでしょうか

あとVS2010じゃないのは何か理由があるのでしょうか?

Re: No title

> ビルド後のイベント
失礼しました。差し替えておきました。

> VS2010じゃない理由
未だにVS2010はC++/cliでIntellisense(自動補完機能)が効かないんです。
なのでC++/cliでもIntellisenseの働く2008を使いました。
ネイティブC++のほうのIntellisenseはVS2010のほうが優秀なんですが。

No title

素早い対応ありがとうございます。
このソフトさえ2010になってくれれば2008をアンインストールできるのですがw
仕方ないですね

変換すれば2010でもいけるんじゃないかと思い変換してビルドしてみたところ設定画面に行こうとすると
アドレス"0x772fb9bc"で例外"0xe0434352"が発生しました
発生モジュール:KERNELBASE.dll
オフセットアドレス:0X0000b9bc
備考:OUTPUT_PLUGIN_TABLE::func_config()[拡張x264出力(GUI)Ex]
と出て設定画面に行けないモノができてしまいました。
ひょっとすると潜在的なバグがあるということなのかもしれないので報告させていただきます。
適当にMessageBoxを挿入してみたところ、frmConfig.hの54行目InitializeComponent();でエラーが出るということまでは分かりました。

No title

更新お疲れ様です。大画面化良いですね。
ひとつ、
x264quiEx.ini内の、chapter.auf 自動出力用コマンドに \が抜けてました。
-chap "%{aviutldir}chapter.txt"

No title

更新お疲れ様です。ダウンロードして使わせて頂きます!
質問)
x264guiEx_Default.iniが統合となっており、実際解凍するとファイルが無いのですが、readmeの使用方法2に「x264guiEx.auo、x264guiEx.ini、x264guiEx_stgフォルダ をAviutlのpluginフォルダにコピーします。」と記載されてました。これはreadme記載がおかしいのでしょうか

No title


上記の記事訂正します。
x264quiEx.iniありました、勘違いしておりました。
申し訳無いです

No title

>VS2010
ありがとうございます。
ん~なんか出ますね…。
調べてみます。が、あまりInitializeComponent()でバグる理由は思いつきません…難しそうです。

>x264quiEx.iniの問題
ありがとうございます。
修正しました。

No title

[MODE_MP3_LAME]

;CBR mode
mode_2=" CBR %{dispList}kbps"
mode_2_cmd="--cbr -b %{cmdList}"
mode_2_dispList=300,250,230,210,190,160,145,130,110,100,90,80,70,50,40
mode_2_cmdList=127,118,109,100,91,82,73,63,54,45,36,27,18,9,0
って数値がおかしくないですか?(0.37と比較するに…)

管理人のみ閲覧できます

このコメントは管理人のみ閲覧できます

管理人のみ閲覧できます

このコメントは管理人のみ閲覧できます

管理人のみ閲覧できます

このコメントは管理人のみ閲覧できます

エラーがでてエンコードできません。

encoded 1943 frames, 47.43 fps, 736.25 kb/s
auo [info]: x264エンコード時間 : 0時間 0分41.1秒
auo [info]: NeroAacEnc で音声エンコードを行います。 AAC-LC ビットレート指定, 128kbps
auo [warning]: 映像一時ファイルのサイズ取得に失敗しました。muxを正常に行えるか確認できません。
auo [info]: mp4box でmuxを行います。音声mux:on, tcmux:off, 拡張モード:なし
auo [error]: mp4box でのmuxに失敗しました。
auo [error]: muxのコマンドラインは…
auo [error]: "C:\Documents and Settings\UG\デスクトップ\プログラム\aviutl\mp4box.exe" -add "E:\テスト.mp4"#video -add "E:\テスト_audio.m4a"#audio -new "E:\テスト_out.mp4"
auo [info]: 総エンコード時間 : 0時間 0分44.2秒


以上のように出てしまいます。
mp4boxはVersion:0.4.6 rev2735を入れてあります。
対策を教えて頂けるとうれしいでs.

Re: エラーがでてエンコードできません。

x264エンコに失敗して、"E:\テスト.mp4"ファイルはできていなさそうです。
x264の設定を確認してみてください。

上手くいかない場合、ログの
auo [info]: arguments passed...
以下x264のオプションを貼ってもらえるとなにかわかるかもしれません。

No title

はじめまして、今回初めて動画のエンコードを行おうとしておりまして、こちらのサイトに大変お世話になっております。

質問なんですが、9/7にのりたけさんから質問があったのと同じで、auoフォルダ内に、「x264guiEx.auo」と「x264guiEx_stg」はあるのですが、「x264quiEx.ini」が見当たりません。
のりたけさんは自己解決したようなのですが、かなりがんばったのですが原因がわかりませんでした。

申し訳ありませんが、「x264quiEx.ini」の有りかについて教えていただけないでしょうか?(解凍方法が悪い?)

Re: No title

拡張子の省略の問題ですかね…?
iniが省略されて「x264guiEx」と見えているかもしれません。

エクスプローラでAltキーを押すと出てくるメニューバーから ツール > フォルダオプション > 表示タブ > 下の方の「登録されている拡張子を表示しない」にチェックが入っていると「x264guiEx.ini」は拡張子「.ini」が省略され「x264guiEx」のみに見えることがあります。

ファイル右クリック > プロパティ から、ファイルの種類のところで拡張子を確認できますので、iniかどうか確認してみてください。

No title

多分ド素人レベルの質問だったと思うんですが、優しい解答本当にありがとうございます。
ご指摘の通り、拡張子の表示の問題でした、お騒がせしてすみません。

vs2010でビルド

最近になって最新のx264を使いたくなり、今更ながらx264guiからExへ移行させていただきました。
こりゃいいや、もっと早く使ってりゃよかった・・・。良いモノ提供してくださってアリガトウゴザイマス。

自分もちょっとイジりたいので、vs2010でビルド試してみました(ウチはもう2008環境消しちまったので)。
設定画面開くところで落ちる原因は、単純にリソースを参照できなかったことが原因みたいです。
vs2010ではマネージ リソースの名前空間にサブフォルダ名が入ってしまうため、旧バージョンから変換したものはリソースを参照できなくなることがあります。

簡単な対応方法としては、frmConfig.resxの構成プロパティ→マネージ リソース→General→「リソース論理名」に「x264guiEx.frmConfig.resources」を指定、です。
(指定しない場合、リソース名はx264guiEx.frm.frmConfig.resourcesのように、サブフォルダ名frmが入ってしまいます)

x264guiExのバグではないので、どうしても2010でビルドしたい人は頑張ってね、ということで。

Re: vs2010でビルド

なるほど、そういうことだったのですね…。

リソースファイルの読み込みに失敗していることまではわかっていたのですが、「どうして失敗するのか、どうすればいいのか」がわかっていなかったので…ありがとうございます。バグじゃなくてよかった。

管理人のみ閲覧できます

このコメントは管理人のみ閲覧できます

ダウンロードについて

ダウンロードページ(skydrive)からダウンロード出来ない場合は、ブラウザが古い、という可能性もあります。

最新のIE(XPならIE8, Vista/7ならIE9)、またはfirefox、chromeの最新版等に更新するとダウンロードできるようになるかもしれません。

No title

こちらでいろいろダウンロードしてエンコ試験してるんですがエンコ開始直後で止まってしまいます。

出力中になってますしエラーが出たり応答なしになるわけではないんですが、パーセンテージも表示されないですしどうなっているのかが分かりません。
時間も短い動画で試験してるのですぐにエンコできると思ったんですが全然終わらないので何かわかるかたいたら教えてください

No title

更新お疲れ様!いつもわかりやすい説明でありがとう
何度もエンコ試しましたが
なかなかうまくできません
二回エンコしてみたらこのようなものが出てきました↓

--------------------------------------------------------------------------------------------------
[C:\Users\User\Desktop\KK.mp4] (1 / 2 pass)
--------------------------------------------------------------------------------------------------
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: arguments passed...
--bitrate 1900 --pass 1 --stats "C:\Users\User\Desktop\KK.stats" --frames 347 --input-res 640x480 --input-csp
nv12 --fps 30/1 -o "nul" "-"
C:\Users\User\Documents\VIDEOWORK\aviutl99l\x264.1471.release03\cli\x264.exe: unrecognised option `--input-res'
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分 0.2秒
auo [info]: 総エンコード時間 : 0時間 0分 0.5秒


--------------------------------------------------------------------------------------------------
[C:\Users\User\Desktop\KK.mp4]
--------------------------------------------------------------------------------------------------
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: arguments passed...
--bitrate 1900 --pass 3 --stats "C:\Users\User\Desktop\KK.stats" --frames 347 --input-res 640x480 --input-csp
nv12 --fps 30/1 -o "nul" "-"
C:\Users\User\Documents\VIDEOWORK\aviutl99l\x264.1471.release03\cli\x264.exe: unrecognised option `--input-res'
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分 0.2秒
auo [info]: 総エンコード時間 : 0時間 0分 0.6秒


もうどうしたらいいかわかりません
対策を教えて頂けたら嬉しいです

Re: No title

x264のバージョンが古いためかと思います。
なるべく最新のx264.exeを使用していただければと。
http://x264.nl/
などからダウンロードしたx264を使用してみてください。

No title

ご返事ありがとうございます
でももう最新のバージョンを使っていますが、状況は変わりませんでした^^; 前と同じくこのようなものがでてました

auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。

それでもう一度記事を読みましたら、自分にはプラグインフォルダがないと発見しました、もしかしてそれが原因ですか?

No title

前のエラーを見ると
  x264.exe: unrecognised option `--input-res'
と出ており、これが原因で失敗しているのがわかります。
翻訳すると「"--input-res"というオプションがわかりません」です。
このオプションはx264 r1672で新しく追加されたものなので、
これよりも古いx264.exeを使っていると、このエラーが発生します。
ディレクトリ名から推測すると、あなたはr1471を使っていたのでしょう。
rigaya氏のアドバイスどおりhttp://x264.nlから
最新版をダウンロードしたならr2200になるはずなので
このエラーが起きることはありません。

もしまた同じメッセージが出ているのであれば、
  ・x264guiExの設定画面で新しいx264.exeを指定するのを忘れている
  ・そもそもダウンロードしたものがおかしい
のどちらかでしょう。
よく確認してみることをお勧めします。

No title

通りすがり様、詳しく書いていただき感謝です。

もうひとつ補足しますと、x264のバージョンはx264を指定するテキストボックスの上にマウスを置くとポップアップで確認できます。

現在(2012.07.10)最新のrev2200でしたら、

x264 バージョン情報
x264 0.125.2200...
(略)

などと出てくるはずなので、そのようになっているか確認してみていただければと思います。

x264guiEx1.50

mp4タブの下のmp4.box.exeの指定がないです。

代わりにremuxer.exeの指定、timelineeditor.exeの指定、muxer.exeの指定が表示され、mp4box.exeのパスを通せないのですが、原因は何が考えられるでしょうか?

Re: x264guiEx1.50

x264guiExでは、v1.47からmp4を出力する際のmuxerとしてmp4boxとL-SMASH muxer両方に対応しました。

remuxer.exeの指定が表示されるのは、x264guiEx.auoと同じフォルダにあるx264guiEx.iniがL-SMASH muxer用のファイルになっているためかと思います。

mp4boxを使用したい場合は、ダウンロード・解凍した際にx264guiEx.auoと同じフォルダに入っているx264guiEx.iniをx264guiEx.auoと同じフォルダにコピーして使用してください。

※x264guiEx.iniはWindowsの設定によっては拡張子が省略され単に"x264guiEx"ファイルと見えることがあります。

Re:Re:Re: x264guiEx1.50

ありがとうございます。

無事、解決しました。

最新のx264を使っているのにバージョンが古いとエラーが表示され出力に失敗してしまいます。

Re: タイトルなし

えと、
・どこのx264でしょうか?
・またログウィンドウにはx264のバージョンはどのように表示されていますか?
の2点、教えていただければと思いますが…。

No title

毎回色々勉強させて頂いております

今回1.57をDLし試してみたのですが、自動マルチパスで目標ビットレートを大幅にオーバー…(200MBを目標にしたら288MBに)
で、上限ファイルサイズ(映像+音声)にチェックして199.9MBに設定してやってみたら今度は大幅にダウン(200MB目標で178MB)
次に上限ファイルビットレートで試したら計算が合わないと出て、サイズ的には197MBという形になったのですが上手い設定方法等ありますでしょうか?

No title

今書き込みを読み返してみて、「どんな計算したんだよお前…」と自己突っ込みしてしまいました…申し訳ない…

計算方法は、付属している計算機を使用
そこに算出されたデータをそのまま反映させるボタンで反映
そしていざエンコ!となると、映像エンコが始まると即座に「計算あわなね~んだよ」と突込みが入り修正
といった具合です

ビットレートの計算

錐様

う~ん…そんなにずれますか…。

うまい設定方法…そうですね…難しいです。

>上限ファイルサイズ(映像+音声)にチェックして199.9MBに設定してやってみたら今度は大幅にダウン(200MB目標で178MB)
とありますが、この時に目標ビットレート目標ビットレートの方に適当に大きい値を入れておけば、勝手に修正されて良い感じになる、というように作ってる…はずなのです。


ちょっと実際にやってみました。

例えば、24分の動画でファイルサイズ200MBにしたい場合、上限ファイルサイズ200MBに設定し、目標ビットレートにはおそらく大きすぎる値、2000kbpsとかを適当に入れておきます。

音声エンコ(128kbps)後に、

上限ファイルサイズの設定を守るには、指定された目標ビットレートは大きすぎます。目標ビットレートを 2000 kbps -> 984 kbpsに変更します。

と出て勝手に修正された結果

encoded 35116 frames, 166.84 fps, 984.17 kb/s (←映像)
出力ファイルサイズ 194.85 MB, ファイルビットレート 1116.00 kbps (←映像+音声)

のような感じで200MBに近いファイルができました。こんな感じで(あえて)自動修正に任せてやればいい感じにできないでしょうか。

No title

返答有難う御座います

色々とやってみた結果、計算機上で出た数値-5位のビットレートで設定すると何となくそれに近い物が出来上がりました
が、自動修正にしちゃうと自分の環境では194~196位になっちゃいます
多分何かを間違っているんだろうと思うのですが難しいですorz

全く話は変わりますが、折角64bit版のx264(BOXも)にしたんですが、CPU使用率が何故か30%前後に…(TSソースのみ、Dソースだと100%になるのも謎)という謎にも直面してますw(POP@4bitさんの所で最新版使用)
エンコ難しい><

ビットレート計算

>自動修正にしちゃうと自分の環境では194~196位になっちゃいます
2passエンコでも指定したとおりのビットレートになるとは限らないので、やや大きめに出てくることもあります。大きくなりすぎて上限設定をオーバーすると再エンコすることになってしまいます。そこで、なるべく再エンコにならないよう、自動修正ではちょっと少なめになるように"余裕"を持たせています。"194~196位になっちゃ"うのはそのためです。

設定画面の右上にある「その他の設定」の「自動マルチパス」のタブで、その余裕の量を調整できます。デフォルトでは"10"ですが、"5"とかに減らしてしてみると"余裕"が減ってぎりぎり近くなるかもしれません。(容量オーバーして再エンコ、の危険も増えますが)

CPU使用率については1pass目がCPU使用率が低いのは仕方ないです。2pass目でもそうなのでしたら、読み込み・フィルタなど、どこが一番遅いのかを調べるしかないです。ts読みが遅いのでしょうか…そんなに遅くはないと思いますが…うーん。難しいです。

No title

>設定画面の右上にある「その他の設定」
あ…そんなのがあったのですね…
どおりでで何度やっても少ない値になっちゃう訳だ…
結局今現在は自動修正OFFの状態で計算機上の数値-5が一番自分の希望容量にどうにか近い値で出来上がる感じかな~…と…
自動マルチパスのタブ、後で試して見ます^^;

CPU使用率なのですが、2PASS目でも良くて50%といた感じです(平均32%~38%と言った感じでしょうか?)
何故かまったく同じフィルタでもDソースの場合は2PASS目は100%になり別の事が何も出来なる位、エンコに心血注いでくれています(CPUには血も心もないですがw)

TSソースで1.5H~2H、Dソースで30min~45minと当然ですがエンコ時間も大分差がでます
フィルタなしでも試してみたのですが結果変わらずと言う事は、TSソースの読み込みに問題があると考えればよいのでしょうか?
質問ばかりで申し訳ない…


No title

読み込みに問題があると思うなら、何故読み込みに使用しているプラグインやらVFAPIやらを情報として提示しないのか...

No title

>読み込みに問題があると思うなら、何故読み込みに使用しているプラグインやらVFAPIやらを情報として提示しないのか...

申し訳ない…よく分からずに使っている為、どのプラグインで読み込んでいるのかが分かっていません

Re: No title

使用されている読み込みプラグインはAviutlの「その他」>「ファイルの情報」の「ファイル制御」からわかります。もし、MPEG2 VIDEO File Readerでしたら、そちらの設定も重要になります。

さて、フィルタ無しでも遅い、ということであれば、
・読み込みが遅い
・そもそもx264の並列化の限界?
とかでしょうか…。

CPU使用率の問題は読み込みのプラグイン、PCのCPU、使用しているフィルタとその設定、x264の設定等、多くの要素が合わさって決まるので、それらのことがわからないと原因の特定は難しいのです…。

No title

何度も返答有難う御座います

教えて頂いたやり方でみると「DirectShow File Reader」で読み込んでいる模様(TSソース、Dソース共に)
CPUはi7-2600k(OCなし)
x264の設定と言うのは…
使用したライブラリ : x264 core 128 [Rev.2216M]x64
エンコードライブラリの設定 : cabac=1 / ref=3 / deblock=1:2:3 / analyse=0x3:0x113 / me=esa / subme=9 / psy=1 / fade_compensate=0.00 / psy_rd=0.50:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / fgo=0 / bframes=5 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=1022 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=17500 / vbv_bufsize=17500 / nal_hrd=none / ip_ratio=1.40 / aq=2:0.60

これでいいのでしょうか?(済みませぬ無知で…)

Re: CPU使用率

別段CPU使用率には関係ありませんが、TS読みにDirectShowはいろいろ微妙なため(よくずれたりする)、
・lsmashinput.aui (L-SMASH works, ダウンロード先:http://pop.4-bit.jp/)
・m2v.aui (MPEG-2 VIDEO VFAPI Plug-In, ダウンロード先:http://www.marumo.ne.jp/mpeg2/)
などのほうがおすすめです…。

正直、入力の問題じゃない気がします。インタレ解除はおそらくAviutlの自動24fpsでしょうか…、それも原因だとは思えないです。x264の設定についてもこの設定で、かつAviutlのフィルタ無しでも、ということなので2pass目のCPU使用率が上がらない理由がちょっと思い当たりません…。

お力になれそうになく、ごめんなさいです。

No title

分かりました、何度も何度もお手間を取らせてしまい申し訳ありませんでした

ちなみに読み込みなのですが、DirectShowよりも上のM2 Vの方が読み込みプラグイン設定で上になっているのですが、何故かDirectshowが使われている状態です…

そもそものTSソースにも問題があるんだろうか…PT2折角手に入れたんですけどね^^;

エンコードに失敗してしまいます

x264のエンコードに挑戦してみようと思い、テストも兼ねて短い動画でやってみたのですが、何度やっても以下のエラーが出て、エンコードに失敗してしまいます。
プラグイン等をインストールし直してみても改善されず困っています…
原因・対策を教えて頂けると嬉しいです。

------------------------------------------------------------------------------------------------------------------------------
[C:\Users\kohaku\Desktop\amarecco310a\test1.mp4] (1 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: 自動マルチパスでの上限のチェックを行う場合は、音声エンコードを先に行います。
auo [info]: NeroAacEnc で音声エンコードを行います。 AAC-LC ビットレート指定, 96kbps, 2pass
auo [warning]: 上限ビットレートの設定を守るには、指定された目標ビットレートは大きすぎます。
auo [warning]: 目標ビットレートを 5800 kbps -> 489 kbpsに変更します。
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: x264 version: 0.129.2230 1cffe9f --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--bitrate 489 --pass 1 --stats "C:\Users\kohaku\Desktop\amarecco310a\test1.stats" --keyint 300 --b-adapt 2 --me umh --subme
8 --direct auto --ref 5 --colormatrix smpte170m --log-level none --frames 3176 --input-res 512x384 --input-csp nv12 --fps
30/1 -o "nul" "-"

encoded 3176 frames, 105.62 fps, 495.31 kb/s
auo [info]: x264エンコード時間 : 0時間 0分30.2秒


------------------------------------------------------------------------------------------------------------------------------
[C:\Users\kohaku\Desktop\amarecco310a\test1.mp4] (2 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: x264 version: 0.129.2230 1cffe9f --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--bitrate 489 --pass 3 --stats "C:\Users\kohaku\Desktop\amarecco310a\test1.stats" --keyint 300 --b-adapt 2 --me umh --subme
8 --direct auto --ref 5 --colormatrix smpte170m --log-level none --frames 3176 --input-res 512x384 --input-csp nv12 --fps
30/1 -o "C:\Users\kohaku\Desktop\amarecco310a\test1.mp4" "-"
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分 9.4秒
auo [info]: 総エンコード時間 : 0時間 0分50.8秒

Re: エンコードに失敗してしまいます

すみません、ちょっとわからないです…。

ログ出力を「info」に変えていただいて、その時のログを見せていただけないでしょうか。それでより詳細な情報が表示され、エラーの原因がわかるかもしれないです。

No title

------------------------------------------------------------------------------------------------------------------------------
[C:\Users\kohaku\Desktop\amarecco310a\test2.mp4] (1 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: 自動マルチパスでの上限のチェックを行う場合は、音声エンコードを先に行います。
auo [info]: NeroAacEnc で音声エンコードを行います。 AAC-LC ビットレート指定, 96kbps, 2pass
auo [warning]: 上限ビットレートの設定を守るには、指定された目標ビットレートは大きすぎます。
auo [warning]: 目標ビットレートを 5800 kbps -> 489 kbpsに変更します。
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: x264 version: 0.129.2230 1cffe9f --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--bitrate 489 --pass 1 --stats "C:\Users\kohaku\Desktop\amarecco310a\test2.stats" --keyint 300 --b-adapt 2 --me umh --subme
8 --direct auto --ref 5 --frames 3173 --input-res 512x384 --input-csp nv12 --fps 30/1 -o "nul" "-"
raw [info]: 512x384p 0:0 @ 30/1 fps (cfr)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
x264 [info]: profile Main, level 3.0
x264 [info]: frame I:14 Avg QP:29.36 size: 14560
x264 [info]: frame P:908 Avg QP:33.06 size: 3578
x264 [info]: frame B:2251 Avg QP:37.31 size: 1374
x264 [info]: consecutive B-frames: 2.0% 3.3% 21.1% 73.6%
x264 [info]: mb I I16..4: 43.7% 0.0% 56.3%
x264 [info]: mb P I16..4: 31.7% 0.0% 0.0% P16..4: 28.5% 0.0% 0.0% 0.0% 0.0% skip:39.8%
x264 [info]: mb B I16..4: 5.6% 0.0% 0.0% B16..8: 20.1% 0.0% 0.0% direct: 6.2% skip:68.1% L0:38.9% L1:45.6% BI:15.5%
x264 [info]: final ratefactor: 29.96
x264 [info]: direct mvs spatial:99.8% temporal:0.2%
x264 [info]: coded y,uvDC,uvAC intra: 42.2% 48.3% 20.0% inter: 9.2% 10.1% 0.5%
x264 [info]: i16 v,h,dc,p: 36% 25% 23% 15%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 23% 27% 13% 6% 6% 7% 6% 6% 6%
x264 [info]: i8c dc,h,v,p: 63% 15% 18% 5%
x264 [info]: Weighted P-Frames: Y:2.9% UV:1.9%
x264 [info]: kb/s:495.01

encoded 3173 frames, 95.23 fps, 495.01 kb/s
auo [info]: x264エンコード時間 : 0時間 0分33.7秒


------------------------------------------------------------------------------------------------------------------------------
[C:\Users\kohaku\Desktop\amarecco310a\test2.mp4] (2 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: x264 version: 0.129.2230 1cffe9f --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--bitrate 489 --pass 3 --stats "C:\Users\kohaku\Desktop\amarecco310a\test2.stats" --keyint 300 --b-adapt 2 --me umh --subme
8 --direct auto --ref 5 --frames 3173 --input-res 512x384 --input-csp nv12 --fps 30/1 -o
"C:\Users\kohaku\Desktop\amarecco310a\test2.mp4" "-"
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分11.4秒
auo [info]: 総エンコード時間 : 0時間 0分57.8秒


infoにして上記のような感じなりました。
お手数ですがよろしくお願いします。

Re: No title

情報ありがとうございます。

が、すみません。同様の設定を再現し、こちらでも試してみたのですが、今のところ原因の特定ができていません。なぜ2pass目の途中で止まってしまうのか…。設定等は特に問題ないはずなのですが…。

お手数おかけしたのに申し訳ないです。もうちょっといろいろ試してみます。

No title

お手間とらせてすみません…
また、何かわかったらお願いします。

No title

「音ズレ」が途中でなってしまいます。
GUI EXのプロファイルでPSPを選んで変換しました。
何回やっても音ズレになるんです。

音声はNeoです。
HEv2 48Kbpsをしています。

DivXをインストールしています。
OS windows XP
frameworck2/3.5も全部インストール済み

音ズレして困るんです

preset slow --profile main --crf 21 --ipratio 1.6 --pbratio 1.4 --qpmin 12 --qpmax 35 --qpstep 10 --qcomp 0.7
--vbv-bufsize 10000 --vbv-maxrate 10000 --aq-strength 0.8 --psy-rd 1:0.25 --scenecut 75 --keyint 300 --min-keyint 1 --bframes
4 --deblock -1:-1 --partitions p8x8,b8x8,i4x4 --subme 7 --merange 32 --no-fast-pskip --no-dct-decimate --sar 1:1 --level 3
--nal-hrd vbr --threads 4 --psnr --deadzone-inter 8 --deadzone-intra 6 --frames 35603 --input-res 480x270 --input-csp nv12
--fps 24753/1001

エンコードしているんです。

音声の設定がしていないからでしょうか?

Re: No title

よくわかりませんが、fpsがおかしな値になっているからではないでしょうか?

Aviutlの「編集」>「再生速度の変更」から元の動画に合わせ、適切なフレームレートを指定すると良いかもしれません。

ファイルの出力に失敗しました。

初めまして。AviUtilのx264を過去に使った事がありますが、1年ほど使っておらずOSが変わってから使っていますが、タイトルの通り、「ファイルの出力に失敗しました。」と出てしまいます。

拡張x264出力EXには以下の通りに表示されます。

------------------------------------------------------------------------------------------------------------------------------
[D:\【動画編集】AviUtil・ゆっくり等\編集済み動画\ゆっくりSpace3 part0.mp4] (1 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: NeroAacEnc で音声エンコードを行います。 AAC-LC ビットレート指定, 128kbps, 2pass
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: x264 version: 0.129.2245 bc13772 --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--preset slow --bitrate 1656 --pass 1 --stats "D:\【動画編集】AviUtil・ゆっくり等\編集済み動画\ゆっくりSpace3 part0.stats"
--qpstep 12 --qcomp 0.7 --rc-lookahead 60 --vbv-bufsize 17500 --vbv-maxrate 17500 --psy-rd 1:0.15 --keyint 600 --min-keyint 4
--bframes 4 --deblock -1:-1 --subme 11 --no-fast-pskip --no-dct-decimate --trellis 2 --colormatrix smpte170m --frames 13774
--input-res 640x360 --input-csp nv12 --fps 60/1 -o "D:\【動画編集】AviUtil・ゆっくり等\編集済み動画\ゆっくりSpace3 part0.mp4"
"-"
raw [info]: 640x360p 0:0 @ 60/1 fps (cfr)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2 AVX XOP FMA4 SSEMisalign LZCNT
x264 [info]: profile Main, level 3.2
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分10.1秒
auo [info]: 総エンコード時間 : 0時間 0分23.9秒

尚、動作環境は、
OS:Win8(32bit)
CPU:4.2GB
ドライブ:400GBx3

となっております。
状況としては、出力の最中に上記の事が発生します。
また、発生のタイミングがバラバラであり、100%に達しても同じメッセージが出てしまいます。

Re: ファイルの出力に失敗しました。

うーん、むずかしい症状です。

落ちるタイミングが不定期というと、オーバークロックが原因の可能性もあります。AMDのBulldozer系のCPUだと思いますが、「CPU: 4.2GHz」とのことで、こちらは定格動作でしょうか?

x264はCPUにかなりの負荷をかけるため、オーバークロック動作では通常より不安定な可能性があります。オーバークロックされているようでしたら、定格で動かしてみたり、クロックを落とすなどを試していただければと思います。

オーバークロックでないのですと…ちょっと原因がわからないかもです。

No title

説明ありがとうございます!
普段からオーバークロックにはしてないので、恐らく違うと…。
そもそもWinXPでは、上記の状態でも普通にx264の変換システムで動いていたのですが、Win8にしたら今の現象が起きてしまいました。
純粋にCPUやメモリを能力の高いのにしたほうがよろしいでしょうか。

Re: No title

違いましたか…見当違いですみません。

> 純粋にCPUやメモリを能力の高いのにしたほうがよろしいでしょうか。
いや、別に大丈夫です。まあ性能が高ければエンコ速度も速くなりますけど、性能が低いから動かないということはないはずですから。

Win8の問題なのでしょうか…。一応Win8(64bit版ですが)もあるので少し試してみたいと思います。

Win8で不安定な問題

>KeyMa様
Win8で試してみようとしたのですが、そもそもうちのWin8機が不安定でテストにならない…という状況で、難航しております。すみません。

No title

感謝です

不正なパラメーターが……

aviutlでエンコードすると下記のようなエラーが発生します。プラグインもaviutlも最新のものを使用しているのですがどうしてもできません。もし解決の策があるなら教えていただけると幸いです。

[G:\実況ソフト\エンコード済み\テストエンコード.mp4] (1 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: NeroAacEnc で音声エンコードを行います。 AAC-LC ビットレート指定, 128kbps, 2pass
auo [warning]: 目標ビットレートを 579 kbpsに設定します。
auo [info]: converting YUY2 -> nv12p, using AVX AVX2
auo [info]: x264 version: core:133 r2334M+r732[x86-64] release 2 --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--preset slow --bitrate 579 --pass 1 --stats "G:\実況ソフト\エンコード済み\テストエンコード.stats" --qpstep 12 --qcomp 0.8
--rc-lookahead 60 --vbv-bufsize 31250 --vbv-maxrate 25000 --aq-strength 0.5 --psy-rd 0.8:0 --keyint 600 --min-keyint 4
--bframes 4 --subme 11 --merange 32 --ref 6 --no-fast-pskip --no-dct-decimate --trellis 2 --colormatrix smpte170m --frames
70067 --input-res 1280x720 --input-csp nv12 --fps 4703255/78467 -o "G:\実況ソフト\エンコード済み\テストエンコード.mp4" "-"
raw [info]: 1280x720p 0:0 @ 4703255/78467 fps (cfr)
mp4 [info]: audio muxing feature is disabled.
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX AVX2 FMA3 LZCNT BMI2
x264 [info]: profile Main, level 4.1
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分29.9秒
auo [info]: 総エンコード時間 : 0時間 1分 9.8秒

Re: 不正なパラメーターが……

すみません、このようにエンコードが始まってしばらくして終了してしまうケースは原因の特定が非常に難しいです…。

オプション自体は特に問題無さそうなのですが…。

No title

一から再設定してもダメでした。調べても自動マルチパスと最新のバージョンにしろとしか解決策がありません(T^T)

No title

>> raw [info]: 1280x720p 0:0 @ 4703255/78467 fps (cfr)
fpsが結構オカシな値な気がしますが関係ないのかな

No title

fpsは関係無いと思いますね-。

というか、x264guiEx使用時以外でもきちんとエンコード出来るのかどうかが気になるかな。
普通にAVI出力でエンコードしたものが 映像の乱れとか フレーム落ちが無いかだとか。
AVI出力でも問題起きるなら、フィルタや入力プラグイン、もしくは入力ファイルそのものが原因ということも考えられますん。

エンコード失敗

プリセットのニコ動 エコ回避 アニメ 高画質でエンコードを行ってるのですが、下記ログが出てエンコードができません。
正常にエンコードする方法はないのでしょうか?
お忙しいところお願いします。

<ログ>
------------------------------------------------------------------------------------------------------------------------------
[C:\JCG\CHO\cho1-1.mp4] (1 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: NeroAacEnc で音声エンコードを行います。 HE-AAC ビットレート指定, 64kbps, 2pass
auo [warning]: 目標ビットレートを 133 kbpsに設定します。
auo [info]: converting YUY2 -> nv12p, using AVX AVX2
auo [info]: x264 version: 0.133.2334 a3ac64b --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--preset slow --bitrate 133 --pass 1 --stats "C:\JCG\CHO\cho1-1.stats" --qpstep 12 --qcomp 0.7 --rc-lookahead 60
--vbv-bufsize 31250 --vbv-maxrate 25000 --aq-strength 0.25 --psy-rd 0.25:0 --keyint 300 --min-keyint 4 --bframes 4 --deblock
1:1 --subme 11 --merange 32 --ref 6 --no-fast-pskip --no-dct-decimate --trellis 2 --colormatrix smpte170m --frames 53682
--input-res 1280x720 --input-csp nv12 --fps 30/1 -o "C:\JCG\CHO\cho1-1.mp4" "-"
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分 3.7秒
auo [info]: 総エンコード時間 : 0時間 0分50.0秒

Re: エンコード失敗

たしかに再現しました。

原因がはっきりとはしませんが、x264のAVX2向けコードに問題があるのかなと思い、AVX2を使用しないようにするとエラーが発生しなくなりました。

場当たり的な回避策になりますが、設定画面の拡張タブの「追加オプション」に
--asm avx
を追加して、AVX2を使用せずにエンコードしてみていただければ大丈夫かと思います。

No title

Aviutlフォルダ: "C:\AviUtl" にインストールします...
neroのインストールは必要ありません。
x264のダウンロードリンクを取得完了
x264の更新は必要ありません。
L-SMASHのダンロードリンクを取得しました。
L-SMASHの更新は必要ありません。
ファイル: x264guiEx.ini のコピーに失敗しました。
Aviutlが実行中であれば、終了した後、再試行をクリックしてください。
ファイル: x264guiEx.auo のコピーに失敗しました。
Aviutlが実行中であれば、終了した後、再試行をクリックしてください。
msvcp110.dll
msvcr110.dll

x264guiEx.auoのインストールが完了しました。
上記の用にでて正しく動きません。もちろんAviutlは開いていません。原因がわかりましたら教えてください!!

Re: No title

何らかの原因でx264guiEx.auo/x264guiEx.iniがロックされてしまっているのでしょうか…。Aviutlは閉じていらっしゃるということですので、ちょっとファイルコピーに失敗する原因がわかりません。

すみませんが、手動にて失敗している2つのファイルをコピーしていただけないでしょうか。

auoフォルダ内の x264guiEx.auo / x264guiEx(.ini) の2つを"C:\Aviutl"内にコピーしていただければと思います。

No title

最初の段階であるインストールが不完全失敗を
起こすようでAviUtlのその他を確認しても
入ってはいない状態です。

neroのインストールバーが途中で停止します。
完了とは表示される為、入っているようで入って
いません。

インストーラーに表示された問題点を記載します。
問題の署名:
問題イベント名: CLR20r3
問題の署名 01: auosetup.exe
問題の署名 02: 0.0.2.0
問題の署名 03: 523d827e
問題の署名 04: mscorlib
問題の署名 05: 4.0.30319.17929
問題の署名 06: 4ffa561c
問題の署名 07: 43c4
問題の署名 08: 13c
問題の署名 09: System.UnauthorizedAccess
OS バージョン: 6.1.7601.2.1.0.768.3
ロケール ID: 1041
追加情報 1: 0a9e
追加情報 2: 0a9e372d3b4ad19135b953a78882e789
追加情報 3: 0a9e
追加情報 4: 0a9e372d3b4ad19135b953a78882e789

オンラインのプライバシーに関する声明をお読みください:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0411

オンラインのプライバシーに関する声明が利用できない場合は、プライバシーに関する声明をオフラインでお読みください:
C:\Windows\system32\ja-JP\erofflps.txt

以上です。XPで使っていた頃は表示すらなく
簡単に入りましたが、問題の署名なんて初めて
見るので訳がわかりません。

インストーラー初期起動時にも次のような
表示が入りました。
.NET Framework 4.30319が必要です。
これは4.5を入れる事により解決しました。
4.5 日本語版のランゲージが影響しているのかさえ
わかりませんので、どうすればいいのか・・・
Windows7 SP1はかなり勝手が違うので意味不明ですorz

よろしくお願いします。

Re: No title

インストーラの問題ですが、
"System.UnauthorizedAccess"
とあるので、UAC(ユーザーアカウント制御)絡みの問題かなと思います。

インストーラを右クリックして「管理者として実行…」を選んで実行するとうまくいかないでしょうか。

よろしくお願いします。

インストールの件について

突然すいません。
インストールの事で質問させていただきたいのですが
L-SMASHのダンロードリンクを取得しました。
と出てしまい、インストールが完全に終了しません。
動画を見てその通りにやったのですがどうしてもインストールできません。
説明不足で申し訳ないのですがよろしくお願いします。

Re: インストールの件について

>nosyku様
「L-SMASHのダンロードリンクを取得しました。」というメッセージはx264guiEx 2.03までの古いメッセージのように思います。この古いバージョンでは、L-SMASHがうまくダウンロードできなくなってしまいました。

ぜひ、新しいx264guiEx 2.03v2 (http://rigaya34589.blog135.fc2.com/blog-entry-414.html)をダウンロードして、再度試していただけないでしょうか。

お手数かけますが、よろしくお願いします。

無事ダウンロードできました!

ありがとうございました!
正常にダウンロードできました!
一人ではわからなかったので大変助かりました。
あの説明文でご理解していただいてありがとうございます。
これからは編集等楽になります!
このソフトに出会えてよかったです!
本当にありがとうございました!

インストールについて

はじめまして。少々質問させてください。
こちらをインストールする際、インターネット環境は必須でしょうか。
実は作成する際のPCが諸事情ありましてネットにつなげられません。
なので単体のダウンロードはできますが、ネット許諾が組み込まれているとインストールできない状況です。
もし、他にやり方がある場合、お手数ですがお教え願えませんでしょうか。
よろしくお願いいたします。

Re: インストールについて

簡易インストーラ(auo_setup)は自動的にネットからファイルをダウンロードするものなので、ネットがないとインストールに失敗してしまいます。(許諾とかではないですが、実行時にファイルのダウンロードができないとちゃんと動きません。)

あらかじめダウンロードしておき、手動で行う方法としては、

x264guiEx 2.xx 導入 (手動)
http://rigaya34589.blog135.fc2.com/blog-entry-371.html

で紹介してあるとおりです。

大雑把に書くと、

1. x264 / nero / L-SMASH をダウンロードしておく

2.「setupフォルダ」の"msvcp110.dll" "msvcr110.dll"の2つをAviutl.exeと同じフォルダにコピーする

3. Aviutl.exeと同じフォルダ、またはプラグインフォルダにauoフォルダのなかに入っている x264guiEx.auo、x264guiEx.ini、x264guiEx_stgフォルダの3つをコピーする

4. x264guiExの設定画面からx264 / nero / L-SMASH (muxer/remuxer/timelineeditor)の場所を指定する

といった手順になります。ちょっと面倒ですが、試してみていただければと思います。

ありがとうございました!

お教え頂いたほうほうで、無事インストール出来ました!

エンコードも上手くいきました。
お手数をお掛けして申し訳ありませんでした。

本当にありがとうございました!

それでは失礼します。

No title

2ヶ月程前からAviUtlを使用しています。動画を作るのは今回が2回目で、1回目に作った動画のエンコード(1ヶ月前)は問題なく出来たのですが、今回作った動画は何度やってもエンコード出来ませんでした。
今回も前回もx264でエンコードをしていて、特に前回と設定などを変えていないはずなのですが…。
原因など分かれば教えていただきたいです。


------------------------------------------------------------------------------------------------------------------------------
[F:\制作物\動画\TAL_up.mp4] (1 / 2 pass)
------------------------------------------------------------------------------------------------------------------------------
auo [info]: converting YUY2 -> nv12p, using SSE2
auo [info]: x264 version: core:140 r2377M+r794[x86-64] release2 --bit-depth=8 --chroma-format=all
auo [info]: x264 options...
--bitrate 450 --pass 1 --stats "F:\制作物\動画\TAL_up.stats" --frames 6121 --input-res 854x480 --input-csp nv12 --fps 30/1
-o "F:\制作物\動画\TAL_up.mp4" "-"
raw [info]: 854x480p 0:0 @ 30/1 fps (cfr)
mp4 [info]: audio muxing feature is disabled.
x264 [info]: using cpu capabilities: MMX2 SSE2Slow SSSE3 LZCNT SlowPalignr
x264 [info]: profile Main, level 3.1
auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
auo [info]: x264エンコード時間 : 0時間 0分27.7秒
auo [info]: 総エンコード時間 : 0時間 0分39.4秒

申し訳ありません…!

たった今自己解決してしまいました…
原因は最近入れた新しいセキュリティソフトでx264がブロックされていたからだったようです…。
セキュリティソフトの設定変えたらエンコード進みました(汗

大変お騒がせしました…。

Re: 申し訳ありません…!

解決して良かったです。セキュリティソフトの誤判定は、意外と多いので困ったものですよね。

No title

X246guiexをインストーラーでインストールすると完了となり、インストールできた事になります。
しかしビデオ圧縮を開いてパスを確認するとx264.exeとpaac.exeの項目が両方空欄になっていてエンコードする事が出来ません。

解決方法を教えてください。
宜しくお願い致します。

Re: No title

うまく動作せず大変申し訳無いのですが、手動にてx264.exeとqaac.exeの位置を指定していただくしかないと思います。

No title

264.exeとqaac.exeが見つかりません。
どこにあるのでしょうか。

解決しました。

いじってみたところ264.exeとqaac.exeが分かりました。

とても便利なプラグインですね。

本当にありがとうございます。

Re: 解決しました。

無事、解決したとのことで良かったです。

No title

はじめまして。
今回x264guiExをインストールして、セットアップしようとして、neroaacencの使用許諾を許可したのですが、ダウンロードのところで
「L-SMASHのダウンロードリンク取得に失敗しました
インストールを続行できません」となり、そこから進めません。
解決方法を教えてもらえますか?

もし他の人と同じ質問をしているのならすみません。

Re: No title

> neroaacencの使用許諾を許可
とありますが、最近のセットアップはneroaacencではなく、qaacを使用するようになっており、使用されている簡易インストーラが古い可能性があります。古いバージョンではダウンロードリンクが切れており、使用できないかと思います。

ちょうど新しいバージョンを公開しましたので、お手数ですが、そちらをお試しいただけないでしょうか?
http://rigaya34589.blog135.fc2.com/blog-entry-902.html

プロフィール

Author:rigaya
アニメとか見たり、エンコードしたり。
連絡先(@を半角にしてください!)
rigaya34589@live.jp
github

最新記事
最新コメント
カテゴリ
月別アーカイブ
カウンター
検索フォーム
いろいろ
公開中のAviutlプラグインとかのダウンロード

○Aviutlプラグイン
x264guiEx 2.xx (ミラー)
- x264を使用したH264出力
- x264guiExの導入>
- x264.exeはこちら>

x265guiEx (ミラー)
- x265を使用したH.265/HEVC出力
- x265.exeはこちら>

QSVEnc + QSVEncC (ミラー)
- QuickSyncVideoによるH264出力
- QSVEncCはコマンドライン版
- QSVEncC 導入/使用方法>
- QSVEncCオプション一覧>

NVEnc + NVEncC (ミラー)
- NVIDIAのNVEncによるH264出力
- NVEncCオプション一覧>

VCEEnc + VCEEncC (ミラー)
- AMDのVCEによるH.264出力

ffmpegOut (ミラー)
- ffmpeg/avconvを使用した出力

自動フィールドシフト (ミラー)
- SSE2~AVX2による高速化版
- オリジナル: aji様

エッジレベル調整MT (ミラー)
- エッジレベル調整の並列化/高速化
- SSE2~AVX対応
- オリジナル: まじぽか太郎様

バンディング低減MT (ミラー)
- SSE2~AVX2による高速化版
- オリジナル: まじぽか太郎様

PMD_MT (ミラー)
- SSE2~FMA3による高速化版
- オリジナル: スレ48≫989氏

透過性ロゴ (ミラー)
- SSE2~FMA3によるSIMD版
- オリジナル: MakKi氏

AviutlColor (ミラー)
- BT.2020nc向け色変換プラグイン
- BT.709/BT.601向けも同梱

○その他
x264afs (ミラー)
- x264のafs対応版

aui_indexer (ミラー使い方>)
- lsmashinput.aui/m2v.auiの
 インデックス事前・一括生成

auc_export (ミラー使い方>)
- Aviutl Controlの
 エクスポートプラグイン版
 エクスポートをコマンドから

aup_reseter (ミラー)
- aupプロジェクトファイルの
 終了フラグを一括リセット

CheckBitrate (ミラー, 使い方, ソース)
- ビットレート分布の分析(HEVC対応)

チャプター変換 (ミラー使い方>)
- nero/appleチャプター形式変換

エッジレベル調整 (avisynth)
- Avisynth用エッジレベル調整

メモリ・キャッシュ速度測定
- スレッド数を変えて測定

○ビルドしたものとか
L-SMASH (ミラー)
x264 (ミラー)
x265 (ミラー)

○その他
サンプル動画
その他

○読みもの (ミラー)
Aviutl/x264guiExの色変換
動画関連ダウンロードリンク集
簡易インストーラの概要

○更新停止・公開終了
改造版x264gui
x264guiEx 0.xx
RSSリンクの表示
リンク
QRコード
QR